小型校园网的设计与组建实验报告 一 . 实验目的
计算机网络是一门实践性较强的技术,课堂教学应该和实践环节紧密结合。计算机网络实验培养学生具有独立进行计算机网络架构和设计能力,提高学生的网络设备使用水平,以及将理论与实践相结合的能力。 二 . 实验环境及设备
2 台路由器、 2 台交换机、 3 台 PC 机 三 . 实验的内容和要求
根据要求,设计并搭建一个校园网。要求进行子网划分和结构设计,并将网络结构建立起来。最后完成网络设备的调试。 四 . 实验说明
某大学分为总校和分校,为该校设计校园网,总校有一个局域网共 20 台计算机,分校由 VLAN 划分为两个局域网,分别有 10 台计算机。该校被分配了一个 C 类网段 210.100.10.0 ,总校和分校各有一台路由器及一台交换机。请进行网络设计,将总校和分校各个局域网连接起来。
根据要求,设计 IP 地址分配表,设计网络结构,画出网络拓扑图。根据设计搭建网络结构。配置网络设备,完成网络调试。
提示: 1 )使用 IP 子网掩码的原理设计 IP 地址分配表。 2 )用到的设备为两台路由器,以及两台交换机。 五 . 实验设计 一、设计思路
总校局域网 20 台计算机,分校 2 个局域网各有 10 台计算机,若要满足要求,则至少需要 5 位主机位,即大小为 2^5=32 台主机的局域网。由于是 C 类网段,最后 8 计算机 ID 码 5 位用作主机号,还有 3 位可以用作子网号,即可以划分 2^3-2=6 个子网( 000 和 111 不可用作子网号),因此子网掩码为 255.255.255.224
( 1111 1111.1111 1111.1111 1111.1110 0000 )。而总校、分校各个局域网只需从 6 个子网中任选其一并且不重复即可。由此可以设计 IP 分配表如下 二、 IP 分配表
用网网络号 途
段 总1 210.100.10.32
校网 路2 210.100.10.64 由器间 分3 210.100.10.96
校网 1 分4 210.100.10.12校8 网 2
三、拓扑结构
子网掩码
255.255.255.224
255.255.255.224
255.255.255.224 255.255.255.224 子起始 IP 地址 网号 00210.100.10.33 1 01210.100.10.65 0
01210.100.10.97
1
10210.100.10.120 9 结束 IP 地址
210.100.10.62
210.100.10.94
210.100.10.126
210.100.10.158
六.实验配置
本人做 主校交换机和路由器配置 主校交换机配置 switchA>en 14 Password:
switchA#configure terminal
Enter configuration commands, one per line. End with CNTL/Z. switchA(config)#vlan 30 // 创建 vlan switchA(config-vlan)#exit
switchA(config)#exit switchA#configure
Enter configuration commands, one per line. End with CNTL/Z.
switchA(config)#interface range fastEthernet 0/1-20 // 将 1-20 端口划入 vlan30 中
switchA(config-if-range)#switchport access vlan 30 switchA(config-if-range)#exit
Switch (config)# interface fastethernet 0/24
Switch (config-if)# switchport mode trunk !配置 trunk 端口 Switch (config-if)# end switchA(config)#exit
switchA#showvlan // 对 switchA 的配置进行验证 VLAN Name Status Ports
---- -------------------------------- --------- ------------------------------- 1 default active Fa0/21,Fa0/22,Fa0/23,Fa0/24, 30 VLAN0030 active Fa0/1 ,Fa0/2 ,Fa0/3 ,Fa0/4 Fa0/5 ,Fa0/6 ,Fa0/7 ,Fa0/8 Fa0/9 ,Fa0/10,Fa0/11,Fa0/12 Fa0/13,Fa0/14,Fa0/15,Fa0/16 Fa0/17,Fa0/18,Fa0/19,Fa0/20 Fa0/24 switchA#
Press RETURN to get started! 主校路由器配置 R2632>en 14 Password:
R2632#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2632(config)#show ip interface brief // 查看路由器的端口 Interface IP-Address(Pri) OK? Status serial 4/0 no address YES DOWN serial 4/1 no address YES DOWN FastEthernet 3/0 no address YES DOWN FastEthernet 3/1 no address YES DOWN Null 0 no address YES UP
R2632(config)#interface fastEthernet 3/0.30 R2632(config-subif)#encapsulation dot1Q 30
R2632(config-subif)#ip address 210.100.10.33 255.255.255.224 R2632(config-subif)#exit
R2632(config)#show ip interface brief Interface IP-Address(Pri) OK? Status serial 4/0 no address YES DOWN serial 4/1 no address YES DOWN
FastEthernet 3/0.30 210.100.10.33/27 YES DOWN FastEthernet 3/0 no address YES DOWN FastEthernet 3/1 no address YES DOWN Null 0 no address YES UP R2632(config)#exit R2632#
Configured from console by console R2632#con
Enter configuration commands, one per line. End with CNTL/Z. R2632(config)#interface serial 4/0 R2632(config-if)#ip ad
R2632(config-if)#ip address 210.100.10.65 255.255.255.224 // 设置交换机 ip 地址和子网掩码
R2632(config-if)#no shutdown R2632(config-if)#end R2632#
Configured from console by console R2632#show ip interface brief Interface IP-Address(Pri) OK? Status s erial 4/0 210.100.10.65/27 YES UP serial 4/1 no address YES DOWN
FastEthernet 3/0.30 210.100.10.33/27 YES UP FastEthernet 3/0 no address YES DOWN FastEthernet 3/1 no address YES DOWN Null 0 no address YES UP R2632#con
Enter configuration commands, one per line. End with CNTL/Z.
R2632(config)#ip route 210.100.10.96 255.255.255.224 210.100.10.66 // 写入静态路由表
R2632(config)#ip route 210.100.10.128 255.255.255.224 210.100.10.66 R2632(config)#end R2632#
Configured from console by console
R2632#show iproute // 对主校路由器配置验证 Codes: C - connected, S - static, R - RIP O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 * - candidate default
Gateway of last resort is no set
C 210.100.10.32/27 is directly connected, FastEthernet 3/0.30
C 210.100.10.33/32 is local host.
C 210.100.10.64/27 is directly connected, serial 4/0 C 210.100.10.65/32 is local host.
S 210.100.10.96/27 [1/0] via 210.100.10.66 S 210.100.10.128/27 [1/0] via 210.100.10.66 R2632#
分校的交换机和路由器配置由小组另一成员完成 分校交换机配置 SwitchA>enable 14 Password:
Switcha#configureterminal ! 进入全局配置模式 SwitchA(config)# SwitchA(config)#vlan 10 SwitchA(config-vlan)#exit SwitchA(config)#vlan 20 SwitchA(config-vlan)#exit
switchA(config)#interface range fastEthernet 0/1-10 switchA(config-if-range)#switchport access vlan 10 SwitchA(config-if)#exit
SwitchA(config)#interface range fastethernet 0/11-20 SwitchA(config-if-range)#switchaport access vlan 20 SwitchA(config-if)#exit
SwitchA(config)#interface fastethernet 0/24 SwitchA(config-if)#switchaport mode trunk SwitchA(config-if)#end
SwitchA#showvlan // 对 switchA 的配置进行验证 VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 d efault active Fa0/23,Fa0/24
10 network2 activ e Fa0/1 ,Fa0/2 ,Fa0/3 ,Fa0/4 Fa0/5 ,Fa0/6 ,Fa0/7 ,Fa0/8 Fa0/9 ,Fa0/10,Fa0/24
20 network3 active Fa0/11,Fa0/12,Fa0/13,Fa0/14 Fa0/15,Fa0/16,Fa0/17,Fa0/18 Fa0/19,Fa0/20,Fa0/24 SwitchA#
Press RETURN to get started! 分校路由器配置 R2632>en 14 Password: R2632#con
Enter configuration commands, one per line. End with CNTL/Z. R2632#con
Enter configuration commands, one per line. End with CNTL/Z. R2632(config)#interface serial 4/0
R2632(config-if)#ip address 210.100.10.66 255.255.255.224 R2632(config-if)#clock rate 64000 R2632(config-if)#no shutdown R2632(config-if)#exit
R2632(config)#interface fastEthernet 3/0 R2632(config-if)#no ip address R2632(config-if)#no shutdown R2632(config-if)#exit
R2632(config)#interface fastEthernet 3/0.10 R2632(config-subif)#no ip address R2632(config-subif)#exit
R2632(config)#interface fastEthernet 3/0.10 R2632(config-subif)#encapsulation dot1Q 10
R2632(config-subif)#ip address 210.100.10.97 255.255.255.224 R2632(config-subif)#exit
R2632(config)#interface fastEthernet 3/0.20 R2632(config-subif)#encapsulation dot1Q 20
R2632(config-subif)#ip address 210.100.10.129 255.255.255.224 R2632(config-subif)#end R2632#
Configured from console by console
R2632#show ip interface brief // 对分校路由器配置验证 Interface IP-Address(Pri) OK? Status serial 4/0 210.100.10.66/27 YES UP serial 4/1 no address YES DOWN
F astEthernet 3/0.20 210.100.10.129/27 YES UP F astEthernet 3/0.10 210.100.10.97/27 YES UP FastEthern et 3/0 no address YES DOWN FastEthernet 3/1 no address YES DOWN Null 0 no address YES UP R2632#con
Enter configuration commands, one per line. End with CNTL/Z. R2632(config)#ip route 210.100.10.32 255.255.255.224 210.100.10.65 R2632(config)#end R2632#
Con figured from console by console R2632#show ip route
Codes: C - connected, S - static, R - RIP O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2
* - candidate default
Gateway of last resort is no set
S 210.100.10.32/27 [1/0] via 210.100.10.65 C 210.100.10.64/27 is directly connected, serial 4/0 C 210.100.10.66/32 is local host.
C 210.100.10.96/27 is directly connected, FastEthernet 3/0.10 C 210.100.10.97/32 is local host.
C 210.100.10.128/27 is directly connected, FastEthernet 3/0.20 C 210.100.10.129/32 is local host. R2632#
R2632 CON0 is now available Press RETURN to get started 七 .实验测试
分校之间的通信: pc2 与 pc3 之间通信 pc3
Pc2
主校与分校的通信: pc1 与 pc3 之间通信 pc1
pc3 :
八.思考题
1 ) 要使总校局域网能够与分校两个局域网通信,如何配置静态路由? 分别为分校的两个网段配置静态路由,并且全部经过的连接分校交换机的路 由器。 针对本实验 , 具体配置为 : Router1# configure terminal
Router1(config)#ip route 210.100.10.96 255.255.255.224 210.100.10.66 Router1(config)#ip route 210.100.10.128 255.255.255.224 210.100.10.66 Router1(config)# end
2 )如果分校两个局域网分别有 20 台主机,交换机快速以太网口是否够 用?如不够用,则如何解决该问题?
不够用,因为,交换机共有 24 个 快速以太网口 ,其中一个作为 trunk 口,剩 余 23 个。若接两个局域网,共 20*2=40 台主机, 快速以太网口 不够用。需要 再加一个交换机或者更换一个有 41 个以上 快速以太网口 的交换机。
因篇幅问题不能全部显示,请点此查看更多更全内容